SSR Not Closing

Get help and insight.
User avatar
oakbarn
Posts: 752
Joined: Thu Jan 05, 2012 2:28 pm
Bot?: No
Location: Texas
Contact:

Re: SSR Not Closing

Post by oakbarn » Wed Jan 17, 2018 1:32 pm

Original Vininity
100-120 vac Input
6.0 vdc 1.0 Amp

Digikey
100-240 vac input
5.9 vdc 1.2 Amps

Digikeys are the one recommended by Curtis and the Original one came with my first BCS 462. It is only logical that something is odd with the BCS as other BCS has a one volt advantage. Also, one of the DINs is "ASSERTED" even with the Green Connectors removed on the problem BCS.

It has worked very well except the last Brew when that I noticed an Out was not turning on the SSR. I thought I had a bad SSR and replaced it. No help. I did a test with an SSR Tester setup I have and that Out would not trigger the SSR.

I also noticed some DINs stopped working (Momentary Push Button Switches) properly.

It happened for no apparent reason that I know of. Since I have the new spare, I am just going to replace it. I have also contacted Brewer's Hardware to see if they have an idea or can fix it.

16nine
Posts: 14
Joined: Sun Dec 30, 2012 10:21 pm
Bot?: No

Re: SSR Not Closing

Post by 16nine » Mon Feb 26, 2018 2:25 pm

oakbarn - depending on the SSR's technology there's usually a relationship between the control [switching] voltage and the amount of voltage it can send along to the load: all is well until the input voltage drops below threshold, after which the amount of LOAD it can switch is reduced until it stops altogether (this happens over a relatively small voltage range). The onboard LED might even be on so all seems good, but there's less and less power being sent to the load. my 5-30VDC driven SSR's require at least 4.7VDC to switch 100% to the load... below that the LED is illuminated but the power getting through drops real quick. obviously not like a mechanical switch where it's either fully ON or OFF

you might check the voltage at the INPUT side of the SSR, not just at the OUTPUT of the power supply: if your PS is marginal and/or there's line resistance, the SSR won't fully "switch" and the LOADed device won't be getting the expected power. if the control voltage checks out it's possible the SSR isn't adequately grounded

hope this helps

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest