Importing old configs 3.7 -> 4.1.1

Get help and insight.
Post Reply
SiMtM
Posts: 5
Joined: Thu Feb 15, 2018 11:33 am
Bot?: No

Importing old configs 3.7 -> 4.1.1

Post by SiMtM » Thu Feb 15, 2018 11:41 am

Hi,

I have a BCS-462 in the brewing setup that I currently have responsiblity for. This is connected to a wireless router, which is then used as the access point for any clients. Nothing of this is connected to the Internet.

Some time ago I upgraded the firmware from 3.7 (I believe) to the newest 4.1.1 firmware. The upgrade went fine, and I really like the new interface.

My problems begin when I try to import the old configs to the brewery via the web-utility. Nothing is really happening and I could use some help to troublehoot. I can access the brewery easily, its just that nothing is happening when I use the web-utilities. I have tried multiple browsers.

I did not set up the brewery and control system in the first place, so I was hoping that I would be able to import the config file with the different ouputs and inputs already named.

Kind regards!

User avatar
JonW
Site Admin
Posts: 1606
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Importing old configs 3.7 -> 4.1.1

Post by JonW » Thu Feb 15, 2018 11:51 am

You have to migrate the old config from 3.x to 4.x. Once migrated, you can backup and restore the 4.x configs.

http://embeddedcc.github.io/bcs-config-migrator/

SiMtM
Posts: 5
Joined: Thu Feb 15, 2018 11:33 am
Bot?: No

Re: Importing old configs 3.7 -> 4.1.1

Post by SiMtM » Thu Feb 15, 2018 12:50 pm

JonW wrote:
Thu Feb 15, 2018 11:51 am
You have to migrate the old config from 3.x to 4.x. Once migrated, you can backup and restore the 4.x configs.

http://embeddedcc.github.io/bcs-config-migrator/
I think I may have phrased myself poorly. That is the web interface I can not get working - and if it is working it's not giving me any indication that is does. I'll have a go at in the weekend.

Is there any tips and tricks to this tool?

Would it be an advantage if I connect via cable to the router that the BCS-462 is connected to or something like that?

User avatar
JonW
Site Admin
Posts: 1606
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Importing old configs 3.7 -> 4.1.1

Post by JonW » Thu Feb 15, 2018 11:22 pm

Does the checkmark, IP address and the box title "BCS 4.0 Device" show green? If not, then it's not seeing your BCS.

The IP address must be entered in the format: http://192.168.1.102
e.g. it need the preceeding http://

SiMtM
Posts: 5
Joined: Thu Feb 15, 2018 11:33 am
Bot?: No

Re: Importing old configs 3.7 -> 4.1.1

Post by SiMtM » Fri Feb 16, 2018 11:00 am

I tried the config migrator again now, nothing is happening. No green ticks on either the config file or the brewery IP. The "Begin Migration"-button is greyed out. Tried Edge, Chrome and Firefox.

The config-file I am trying to use is named: bcs_sys.cfg - this is correct, right?

When I looked at the source code, I saw some jquery-links that was unavailable to access when I was at the local brewery network.
Am I supposed to be simultanously connected to the internet as well as the brewery in order to make this work? Because the brewery is currently on an offline network (And I really dont have a possibility to connect it to the internet either).

User avatar
JonW
Site Admin
Posts: 1606
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Importing old configs 3.7 -> 4.1.1

Post by JonW » Fri Feb 16, 2018 11:24 am

The config migrator is an online tool. If the jquery links aren't working, well, there's your problem.

It is possible to save the code locally and execute from there, but you need to also save the js files too.

SiMtM
Posts: 5
Joined: Thu Feb 15, 2018 11:33 am
Bot?: No

Re: Importing old configs 3.7 -> 4.1.1

Post by SiMtM » Fri Feb 16, 2018 11:29 am

Yeah I figured that was the problem.

Used the chrome extension as described here https://forum.embeddedcc.com/viewtopic.php?f=10&t=2989

worked flawlessly!

User avatar
JonW
Site Admin
Posts: 1606
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Importing old configs 3.7 -> 4.1.1

Post by JonW » Fri Feb 16, 2018 12:05 pm

Is your BCS on 4.0.0 or 4.1.1?

SiMtM
Posts: 5
Joined: Thu Feb 15, 2018 11:33 am
Bot?: No

Re: Importing old configs 3.7 -> 4.1.1

Post by SiMtM » Fri Feb 16, 2018 12:54 pm

JonW wrote:
Fri Feb 16, 2018 12:05 pm
Is your BCS on 4.0.0 or 4.1.1?
I believe it is 4.1.1

Edit: I am not close to the brewery atm. Can check tomorrow if if you need it with 100 % certainity :)

User avatar
JonW
Site Admin
Posts: 1606
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Importing old configs 3.7 -> 4.1.1

Post by JonW » Fri Feb 16, 2018 9:12 pm

I don't really need it, but the solution link you posted was something that was only needed on 4.0.0, so I was just curious on the version.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest