Firmware update gone wrong

Get help and insight.
thb
Posts: 19
Joined: Tue May 19, 2015 11:10 am
Bot?: No

Firmware update gone wrong

Post by thb » Fri Feb 23, 2018 9:00 am

Hi
I updated our spare bcs 460 from 3.7.1 to v 4.1.1 no problems.
Then : update of active brew BCS 462. ... using exact same setup execept for longer cable.
The transfer of data timed out. And kept doing it ((Tftpd by ph Jounin)
and finally I had to abort. Now I can't connect to the BCS.
How do I proceed? Brewday tomorrow.
Bjorn

User avatar
JonW
Site Admin
Posts: 1622
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Firmware update gone wrong

Post by JonW » Fri Feb 23, 2018 9:46 am

Have you done a power cycle on the BCS?
Have you checked if it pulled a different IP?
It's possible it did update - have you used both 3.x and 4.x locators to try and find it?

thb
Posts: 19
Joined: Tue May 19, 2015 11:10 am
Bot?: No

Re: Firmware update gone wrong

Post by thb » Fri Feb 23, 2018 9:47 am

Further info :
Done resets: 1...25 sec, 1 : 15 sec. And and more 15 sec. No light in com port.!
Bjorn

thb
Posts: 19
Joined: Tue May 19, 2015 11:10 am
Bot?: No

Re: Firmware update gone wrong

Post by thb » Fri Feb 23, 2018 9:48 am

Power cycle...yes
Finder cant find it.
No com

thb
Posts: 19
Joined: Tue May 19, 2015 11:10 am
Bot?: No

Re: Firmware update gone wrong

Post by thb » Fri Feb 23, 2018 10:01 am

What about a more than 30 sec reset? How do I proceed?

User avatar
JonW
Site Admin
Posts: 1622
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Firmware update gone wrong

Post by JonW » Fri Feb 23, 2018 11:03 am

Have you tried a different ethernet cable? Sounds to me like it isn't on the network. The green terminal strips unplug, so you can move the BCS to the router and use a short cable for troubleshooting.

thb
Posts: 19
Joined: Tue May 19, 2015 11:10 am
Bot?: No

Re: Firmware update gone wrong

Post by thb » Fri Feb 23, 2018 12:02 pm

Hi
460 and 462 side by side same cables and power.
460 :updated to 4.1.1 no problem

462 :Checked ok but sluggish before update from 4.0.0 b46yd00f to 4.1.1
Update aborted after approx 35 minutes. It kept timing out. It got as far as 35% then continously started over.
The tftpd was at standard settings first then I tried to change TFTP timeout and Max retransmit, but to no avail.
Power cycled several times.
Reset 15 sec several times.
No lights at the com port.

Other reset options?

Bjorn

thb
Posts: 19
Joined: Tue May 19, 2015 11:10 am
Bot?: No

Re: Firmware update gone wrong

Post by thb » Fri Feb 23, 2018 1:36 pm

Still researching.
No lighs are on at the comm port
Can the BCS be reset? if so : to a given IP?
Then can I get info to program the Tftpd32 to push the firmware?
Otherwise it looks like I have to ship the 462 out.

Regs
Bjorn

User avatar
JonW
Site Admin
Posts: 1622
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Firmware update gone wrong

Post by JonW » Fri Feb 23, 2018 3:06 pm

You've done the only reset options available. We can directly connect to the board and flash the processor, but it will require shipping it.

thb
Posts: 19
Joined: Tue May 19, 2015 11:10 am
Bot?: No

Re: Firmware update gone wrong

Post by thb » Fri Feb 23, 2018 3:11 pm

ok since it is not showing a light at the comm port, does it for sure mean that it will not receive an update?
Pls give me shipping adress.
Bjorn R.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests