Blichmann Fermenator Control

Discussion of the physical aspects
wyowolf
Posts: 53
Joined: Sun Nov 08, 2015 1:58 pm
Bot?: No

Re: Blichmann Fermenator Control

Post by wyowolf » Mon Aug 27, 2018 5:23 am

oakbarn wrote:
Fri Aug 24, 2018 4:59 pm
I have many probes. If I was to do it over again, I would always buy 12" probes and use with Thermowellls. You can easily put a 12" probe in a 2", 3", 4", 5", 6" or 12" Thermowelll. The sensor is at the end of the Probe. I have found that they register very well after a few minutes without any need for thermal gel. Just make sure you "bottom" the probe in the Thermowelll.
any particular pump I should look at ?

https://www.amazon.com/Tiger-Pumps-Subm ... uatic+pump

User avatar
oakbarn
Posts: 810
Joined: Thu Jan 05, 2012 2:28 pm
Bot?: No
Location: Texas
Contact:

Re: Blichmann Fermenator Control

Post by oakbarn » Mon Aug 27, 2018 5:57 pm

Yes, you just use regular SSR to control another electrical widget ({Pump/Glylcol Chiller/Element) You just the correct size for the Widget and your circuit. The DIY Glycol should work on a normal circuit, depending on what the rating of the AC is. The Pump should work on a normal 15 amp circuit. Use Hysteresis Mode in the Process Editor for most things that are not heating Elements. You do not want to "short cycle" your compressor on the DIY Glycol Chiller. That means it should run then be off for at least 15 minutes according to what I could find on the internet. I am not an electrician or AC Repairman. I am a retired pilot so take what I say with salt! :lol:

wyowolf
Posts: 53
Joined: Sun Nov 08, 2015 1:58 pm
Bot?: No

Re: Blichmann Fermenator Control

Post by wyowolf » Sun Sep 30, 2018 6:04 am

Ok finally got around to wiring this... the SSR turns on and power comes from SSR to plug... but when I plug in AC nothing?? even though there is power at plug?? i plugged water pump just to check... same nothing... i can plug AC in to water pump and it works...
possible the SSR is only letting small voltage through? it is brand new...

User avatar
JonW
Site Admin
Posts: 1627
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Blichmann Fermenator Control

Post by JonW » Sun Sep 30, 2018 8:54 am

SSR make/model? Wiring diagram?
SSR's "leak" a small current when off.

wyowolf
Posts: 53
Joined: Sun Nov 08, 2015 1:58 pm
Bot?: No

Re: Blichmann Fermenator Control

Post by wyowolf » Mon Oct 01, 2018 3:45 am

Sorry dont have that.. but they are the same ones I use for the element and the pump... the red light comes on, and 120V shows at the plug...i will have to recheck connections, maybe one of the N or G isnt quite connected in the plug itself.

I just ran from the black incoming leg to the SSR then to the plug, G and Ns to the same place as the others in the panel...

wyowolf
Posts: 53
Joined: Sun Nov 08, 2015 1:58 pm
Bot?: No

Re: Blichmann Fermenator Control

Post by wyowolf » Mon Oct 01, 2018 2:16 pm

Just to update, one of the SSRs was bad :( brand new... the other was one of the N was not making good contact in receptacle...

wyowolf
Posts: 53
Joined: Sun Nov 08, 2015 1:58 pm
Bot?: No

Re: Blichmann Fermenator Control

Post by wyowolf » Mon Oct 01, 2018 2:20 pm


Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests