my Brew Buddy app is possessed!

iPhone Apps created to interface with BCS Control Systems
Post Reply
clearwaterbrewer
Posts: 383
Joined: Wed Feb 09, 2011 3:43 pm
Bot?: No
Location: Clearwater, FL
Contact:

my Brew Buddy app is possessed!

Post by clearwaterbrewer » Sat Jul 09, 2011 7:46 pm

Brew Buddy toggles processes on and off continuously on my BCS-462....

I have the web interface up and when I start Brew Buddy, things get really wacky if I already have a process going or start a process with either the web ui or Brew Buddy. Brew Buddy apparently just keeps toggling processes on and off, even if I start a un-configured process... sometimes I have to 'stop all' several times on the web ui to get my relays and SSR's from seeming possessed...
(it does it faster on local connection, but if I turn off WiFi on phone and use 'auth-example' login, it slows down...) It is like the process of 'checking' is actually 'updating' and there is a feedback loop.

Things work perfectly without Brew Buddy started on phone.

Firefox 5.0
BCS 3.3
app store says everything is up to date...

troubleshooting -

closed browser
killed Brew Buddy app on my iPhone4 with the double home click
power off phone
power cycled BCS
powered on phone
waited 5 minutes

start Brew Buddy
enable control
go to processes page
start mash process
process immediately starts toggling, and I am unable to get it to stop unless I hit the home button...
if i restart Brew Buddy, it starts toggling...

I can crash Brew Buddy by rapidly tapping on the process on/off button


Reset Controller to defaults...
start a process... it toggles about 10 times and then shuts process off

disconnected all connectors except network and power, same issues...

I tried to load my saved settings, and they would not take... power-cycled, etc, still no-go.. tried to do firmware update, but it would not request file from tftp server...

I finally did a 10 second push on the reset button to do a hard reset, and was able to upload my system and process settings... whew...

issue with Brew Buddy cycling process still there after all that...

Scruff_Higgins
Posts: 1
Joined: Mon Aug 01, 2011 6:04 pm
Bot?: No

Re: my Brew Buddy app is possessed!

Post by Scruff_Higgins » Mon Aug 01, 2011 6:08 pm

I am having similar issues with BCS-460 v3.1 and BrewBuddy. The manual mode on BrewBuddy works fine and turns my elements and pumps on and off quickly, however toggling a process causes it to switch back and forth on its own, about 10 times, then exits the BrewBuddy app. It does look like it is communicating with the BCS during his possessed state as the SSR's flicker.

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest