Trying to restore backup to BCS-462 and hanging

Get help and insight.
Post Reply
smcinco
Posts: 5
Joined: Wed Jul 26, 2017 10:42 pm
Bot?: No

Trying to restore backup to BCS-462 and hanging

Post by smcinco » Wed Apr 01, 2020 8:08 am

Hi there-

I took a long hiatus from brewing (silly me). When I went to fire up my ferm control BCS, it had lost its config and was seemingly wiped clean. I plugged it into my router and found it, and with DHCP enabled the IP address is 192.168.1.127. When I try to restore from a backup the backup restore utility IDs the 'BCS 4.0 device' as 192.168.1.5.

The restore utility progress bar does not move. I'm wondering if the IP address that the utility is trying to find the BCS at is an issue? Something else simple I'm overlooking? I tried to disable DHCP and then my PC could not find the BCS, so I had to do a hard restore and no I'm back to square 1.

As further background, the restore utility gives me the message: 'Different Device Types
This backup was created on a different device type. The restore will probably work fine, but there may be some settings which are not applied properly'


Thanks in advance for any help.

User avatar
JonW
Site Admin
Posts: 1711
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Trying to restore backup to BCS-462 and hanging

Post by JonW » Wed Apr 01, 2020 2:41 pm

The web based backup/restore utility always defaults to using the last IP address that you talked to the BCS with. In this case, it sounds like it was on .5. You can override what is displayed and input your .127 address and when tabbing off the IP address, you should get a green check mark showing it has seen the BCS.

smcinco
Posts: 5
Joined: Wed Jul 26, 2017 10:42 pm
Bot?: No

Re: Trying to restore backup to BCS-462 and hanging

Post by smcinco » Wed Apr 01, 2020 4:23 pm

Jon-

Roger that, thanks for your quick response. Sorry I forgot to add in my original post that the 'BCS 4.0 Device' default .5 address box is read only, cannot overwrite. Tried both on Mac and PC. Is there anywhere I can change my .127 address to .5 for simplicity? Anything else I should try?

Thanks!

User avatar
JonW
Site Admin
Posts: 1711
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Trying to restore backup to BCS-462 and hanging

Post by JonW » Thu Apr 02, 2020 9:36 am

There's two ways to set a specific address. The first (and my preferred) is to set a DHCP reservation in your router so that each time the BCS reboots (even if you do a hard reset of the config) it will always come back to the same IP address. The second way is you can set it in the BCS by going to the Settings page and Networking section and you can set a static IP there. If you do a hard reset though, it goes back to DHCP mode and you'll have to use finder to locate it again. That's why I like the reservation method, but they'll both get you there.

smcinco
Posts: 5
Joined: Wed Jul 26, 2017 10:42 pm
Bot?: No

Re: Trying to restore backup to BCS-462 and hanging

Post by smcinco » Thu Apr 02, 2020 11:05 am

Ok thanks! Got the IP address changed in Networking, will work on the permanent fix later. It's still hanging (on both PC and Mac), 'Restoring...' progress bar goes nowhere. How long should the restore take? Could 'different device types' be an issue?

User avatar
JonW
Site Admin
Posts: 1711
Joined: Sun Jul 18, 2010 7:51 am
Bot?: No
Location: Huntington Beach, CA
Contact:

Re: Trying to restore backup to BCS-462 and hanging

Post by JonW » Thu Apr 02, 2020 11:43 am

Is the backup not from this BCS? Also, you should update to the latest firmware. 4.0 is no bueno.

smcinco
Posts: 5
Joined: Wed Jul 26, 2017 10:42 pm
Bot?: No

Re: Trying to restore backup to BCS-462 and hanging

Post by smcinco » Thu Apr 02, 2020 4:28 pm

Yes, backup is from this BCS. Got the firmware updated to 4.1.2 or should I go to .3? I tried it again and it still hangs up. Also, as another note the text in the dialog box to select the BCS backup file stays yellow, as does the 'Different Device Types...' warning. Maybe I'm not pointing it to the right place? How would it know it's from a different type? File extension? The file extension of this backup is .json, not sure if it's wanting to see something different?

smcinco
Posts: 5
Joined: Wed Jul 26, 2017 10:42 pm
Bot?: No

Re: Trying to restore backup to BCS-462 and hanging

Post by smcinco » Sun Apr 05, 2020 12:52 pm

Quick Update:

I was able to restore from backup. I ended up copying in some superfluous text into the 'BCS 4.0 Device' dialog box, which then allowed me to edit the IP address in the box. Hope this helps.

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests